Skip to toolbar
Menu Close

Mesa Nomad channel (auto) changing issue…..

Home Forums Tech Forum Mesa Nomad channel (auto) changing issue…..

Tagged: 

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #151007
    Mktrat
    Keymaster
    Offline
    Been thanked: 9527 times

    Ok, so first off, yes it’s a guitar amp.  I apologize in advance.

     

    Here’s the issue.

    Channel one is fine.

    Channel two is usually fine.

    Channel three is ok sometimes.

     

    The weird thing is that when using channels 2 or 3 the amp gets quiet and static-y, and actually switches between the two channels intermittently.

     

    I’m not sure how to trouble shoot this issue.

     

    https://mesaboogie.com/support/out-of-production/nomads.html

    The exact amp in question is a Nomad 45 4×10.

    There's something about this that's so black, it's like how much more black could this be?
    And the answer is none. None more black. -Nigel Tufnel

    #151047
    NSYMCE
    Participant
    Offline
    Been thanked: 2126 times

    I’m not sure how to trouble shoot this issue.

    Me either, I think a schematic is probably more or less mandatory for starters.

    1 user thanked author for this post.
    #151051
    Mktrat
    Keymaster
    Offline
    Been thanked: 9527 times

    I’m not sure how to trouble shoot this issue.

    Me either, I think a schematic is probably more or less mandatory for starters.

    I’ll look for one.  I think I still have the original paperwork somewhere.

    There's something about this that's so black, it's like how much more black could this be?
    And the answer is none. None more black. -Nigel Tufnel

    1 user thanked author for this post.
    #151168
    Andyman001
    Participant
    Offline
    Been thanked: 5179 times

    Ok, so first off, yes it’s a guitar amp. I apologize in advance.

    Here’s the issue.

    Channel one is fine.

    Channel two is usually fine.

    Channel three is ok sometimes.

    The weird thing is that when using channels 2 or 3 the amp gets quiet and static-y, and actually switches between the two channels intermittently.

    I’m not sure how to trouble shoot this issue.

    https://mesaboogie.com/support/out-of-production/nomads.html

    The exact amp in question is a Nomad 45 4×10.

    I’d start by looking at the footswitch/ connections that control the channel switching.

    "I reject your reality and substitute my own"

    1 user thanked author for this post.
    #151169
    Mktrat
    Keymaster
    Offline
    Been thanked: 9527 times

    I’d start by looking at the footswitch/ connections that control the channel switching.

    I’ll take apart the switch tonight.  That would kinda make sense.  I should try the selector on the back to switch channels.  Duh!!

    There's something about this that's so black, it's like how much more black could this be?
    And the answer is none. None more black. -Nigel Tufnel

    2 users thanked author for this post.
Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

For New Registrations, "Contact Us" and Tell us Your Favorite Movie.